[FAQ]Setup / Upgrade issue - cannot complete the setup process

Author
APGvNext Sam
vNext Dev
  • Total Posts : 13218
  • Joined: 2001/05/23 00:00:00
  • Status: offline
2008/07/18 20:14:27 (permalink) Setup
0

Setup / Upgrade issue - cannot complete the setup process

If you can't even see the software's setup interface, you need to first make sure the forum folder is set as an Application first. We need to do this because the software needs to use its own web.config and bin folder. I will show you what it looks like when the folder is marked correctly below:

NOTE: The folder names appear on the screen shots are just examples. You can name your folder and application any way you want

IIS 6:

 
IIS 7:

 
Make sure the server is set up as the above screen shots.
 
The setup program (~/setup) tests your web server and sql server extensively and will report issues on every step of the setup process. In case you don't see any issue being reported and still cannot get through setup program, please check out the error log folder ~/upfiles/logs/

In this folder, you should see files with names like 2013.01.18-500.xml . If you don't see any files there, you probably didn't set up the folder permission correctly and the forum software is unable to log the errors. See this article to set up the folder permission required before trying to set up the software.
 
Open these xml logs using either IE or Wordpad, and you should be able to see the <Details> of the error(s).

Report these errors to our support forum and I will help you solve the problem. Alternatively, you can also attach the file with your report. DO NOT COPY n' PASTE the content of the xml file into the editor, as this will become very hard to read.


The following are the most common reasons for setup/upgrade failure:
  1. You are not using SQL 2005 / 2008 / 2012
    Click to see the Solution

    Our software does not support any SQL server version before 2005, so you cannot currently install the software on your machine. See System Requirements for more info.
    close
  2. SQL Server was not set up to allow remote connection (Microsoft SQL Server, Error: 53)
    Click to see the Solution

    If the error log shows a line like the following:
    this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections.


    You will have to enable remote connection on your SQL server. See this link and this link for more info.
    close
  3. Your site root web.config has some settings that conflict with the software
    Click to see the Solution

    It is possible that settings defined in your site web.config conflict with the software's settings. Since web.config settings propagate down the folder hierarchy (to child applications), sometimes it could cause issues.

    You can edit the web.config files in the parent folders (could be more than one) like this to prevent inheritance issue:
    <location path="." inheritInChildApplications="false"> 
        <system.web>
        ...
        </system.web>
    </location>
    <!-- if you are on IIS 7 Integrated pipeline mode -->
    <location path="." inheritInChildApplications="false">
        <system.webServer>
        ...
        </system.webServer>
    </location>

    close
  4. On IIS 7, your host does not allow HTTP Compression to be managed by the application
    Click to see the Solution

    The error log shows a line like the following:
    Http-Error 500.19 Module DynamicCompressionModule this configuration can't be used because it is blocked.

    The reason for this is in the web.config file provided with the forum software. There is the tag:
    <urlCompression doStaticCompression="true" doDynamicCompression="true"/> 

    So, the software comes with a "gzip/deflate compression" enabled setting.

    However, in some server configurations this particular setting is set NOT to allow making changes on this attribute at the Application level configuration file.

    You have to allow this by editing the applicationHost.config file located under \windows\system32\inetsrv\config. Open the file with a text editor andsearch for:
    <section name="urlCompression" overrideModeDefault="Deny" /> 

    change "Deny" to "Allow" and you can proceed.

    Alternatively, you can remove the urlCompression line in the software's web.config file.
    close
  5. You are using the browser installed on YOUR SERVER to set up the software
    Click to see the Solution

    Browsers on the server often are limited in terms of functionality due to server security reasons, and therefore can have trouble running AJAX application.

    Please do not use this function limited browser on your server to try to set up the forum. Connect to your server from your own desktop and use the most updated version of your browser (IE / Firefox / Chrome....) to run the setup program.
    close
  6. SQL Server login failure
    Click to see the Solution

    If you see error like
    System.Data.SqlClient.SqlException: Login failed for user 'Samuel'

    in the log file, it means the account you use for the forum connection was not set up properly. It is either a) the user was not set up in the SQL server b) the connection string you specified in web.config is wrong
    close
  7. Your server has some software installed that interferes with HTTP communication
    Click to see the Solution

    If you can't complete the activation step, it's likely your server has some software installed that rewrites URL. In some cases your server will keep redirecting you to the same page that results in a browser error.

    See this page if you can't complete the activation step during setup.
    close
  8. You run into 403 Forbidden: Access is denied error
    Click to see the Solution

    You can try adding the following to the web.config file (the bolded part)
      <system.webServer>
        <modules runAllManagedModulesForAllRequests="true"></modules>
        <handlers>
          <remove name="UrlRoutingHandler"/>
        </handlers>
        <rewrite>
            <rules>
                <clear/>
            </rules>
        </rewrite>
      </system.webServer>

    close
post edited by APGvNext Sam - 2014/07/16 01:03:29

Attached Image(s)

#1
Jump to:
© 2018 APG vNext Commercial Version 5.5